Apache And Php Update

تحديث الأباتشي و محرك البي أتش بي و الموديلات التي تئتي مع الأباتشي أمر مهم جداً , لذا كن حريصاً على تحديث البرامج في أسرع وقت لتفادي المشاكل في المستقبل , وبل الذات مشاكل الحماية فا هيه من أهم الأمور التي تجعلك مدير سيرفرات ناجح أن شاء الله , المهم دعونا ندخل في صلب الموضوع ونبدأ بل التحديثات .

سوف نحتاج إلى استخدام الشيل SSH  و لوحة التحكم WHM

أولاً قم بتسجيل الدخول إلى SSH بمستخدم الروت root

تسجيل دخول ………. تم 🙂

نفذ هذا الأمر لبدأ التحديث

/scripts/easyapache 

ملاحظة : يمكنك استخدام الماووس أو الكيبورد في اختيار الإعدادات

<oPreviously Saved Config (** DEFAULT **)  Start customizing based on profile

[

_____________________________________________________________________

<oApache 2.2  [Next Step

 

[XPHP 5  <o5.2.6  [Next Step]

 

[XMod SuPHP  
[XFrontpage
[XMod Bandwidth
[ ] Tomcat
[ ] Mod Mono v1.2.4
[ ] Mod Perl
[XMod Security
[XSuhosin for PHP
[XZend Optimizer for PHP  
[ ] EAccelerator for PHP
[XIonCube Loader for PHP  [Advanced Configuration

Apache Builtin Modules  
[XAsis
[ ] Auth Digest   
[ ] AuthnAlias    
[ ] AuthnAnon
[ ] AuthnDBD 
[ ] AuthnDBM 
[XAuthnDefault  
[ ] AuthnzLDAP    
[ ] AuthzDBM 
[ ] AuthzOwner    
[ ] Bucketeer
[ ] CGI (required to run CGI scripts and/or PHP as CGI)   
[XCGId (required to run CGI scripts or PHP as CGI with threaded MPMs)  
[ ] Cache    
[ ] CaseFilter    
[ ] CaseFilterIn  
[ ] Cern Meta
[ ] Charset Lite  
[ ] DAVFs    
[ ] DAVLock  
[ ] DBD 
[ ] Dav (Among other things mod_dav can be used by 

DAV enabled Frontpage clients instead of FP extensions)  
[ ] Deflate  
[ ] Disk Cache    
[ ] Distcache
[ ] Dumpio   
[ ] Echo
[XEnv 
[XExpires  
[ ] ExtFilter
[ ] Mod FCGID (fastcgi support)  
[ ] File Cache    
[XFileprotect (Prevent Users from reading other webroots)    
[XFrontpage
[XHeaders  
[ ] Ident    
[ ] Imagemap 
[X] Include  
[ ] Info
[ ] LDAP
[ ] Log Forensic Apache Builtin Modules continued  
[ ] MPM Event (Before choosing *anyMPM read and understand the documentation)    
[ ] MPM Prefork ((recommendedBefore choosing *any

MPM read and understand the documentation)   
[ ] MPM Worker (Before choosing *anyMPM read and understand the documentation)   
[ ] MemCache 
[ ] Mime Magic    
[ ] Optional Fn Export 
[ ] Optional Fn Import 
[ ] OptionalHookExport 
[ ] Optional Hook Import    
[XMod SuPHP
[Xmod_proxy
[XSpeling  
[XUniqueId 
[ ] Usertrack
[ ] Version  
[ ] Vhost Alias   
   
Other Modules  
[ ] EAccelerator for PHP (v0.9.5.2 – please read URL to fully understand this option)   
[ ] IonCube Loader for PHP (3.1.32 – please read URL to fully understand this option)   
[ ] Mod Bandwidth (v2.1 for Apache 1.3v0.8 for Apache 2.x – see URL for details
[ ] Tomcat (v5.5.25 – Experts ONLY: Do not install this unless you have a tomcat admin.)
[ ] Mod Mono v1.2.4 (Experts ONLY: Do not install this unless you have a mono admin)    
[ ] Mod Perl (v2.0.3 – not needed to run CGI scripts)
[XMod Security (v1.9.5 for Apache 1.3v2.1.3 for Apache 2.x)
[XSuhosin for PHP (v0.9.20 – please read URL to fully understand this option)    
[XZend Optimizer for PHP (3.3.0 – please read URL to fully understand this option)    
   
PHP 5.x   
[XBcmath   
[ ] Bz2 
[XCGI 
[XCalendar 
[ ] Concurrent DSO patch (Allows PHP 4 and 

to load simultaneously as Apache modules 

(not compatible with Zend optimizer and some extensions))
[XCurl
[XCurlSSL  
[XCurlwrappers  
[ ] Dbase    
[ ] Discard Path (may interfere with running PHP as CGI)  
[XExif
[XFTP    
PHP 5.x continued   
[ ] Fastcgi  
[ ] Force CGI Redirect 
[XGD  
[ ] Gettext  
[XIconv (Support iconv character set conversion facility)    
[XImap
[ ] Java
[ ] MM  
[XMagic Quotes  
[ ] MailHeaders   
[XMbregex  
[XMbstring 
[ ] Mcrypt   
[ ] Mhash    
[XMime Magic    
[ ] Ming ((Not Recommended due to various problemsusing ming library 0.3.0
[XMysql (compile mysql support against php bundled libraries

 (if the system mysql is checked it takes precedence of this option))  
[XMysql of the system (compile mysql 

(and mysqli if its checkedsupport against the system libraries)    
[ ] MySQL “Improved” extension. (MySQLi does not replace the standard MySQL 

extensionRequires MySQL 4.1 or later. !! mysqli may not work on all system$
[XOpenssl  
[ ] PDO ((unsupported experimentalIncludes SQLite support.

 Other drivers (mysql etccan be installed with PECL)    
[XPOSIX    
[XPath Info Check    
[XPear
[ ] PGsql (Requires PostgreSQL 7.3 or higher to already be installed

You can do that with /scripts/installpostgres)  
[ ] Pspell   
[ ] SNMP (Requires the SNMP Dev libraries to be installed first!!!) 
[ ] SOAP
[XSafeMode 
[ ] Safe PHP CGI (prevents users from overriding system php.ini)    
[XSockets  
[XTTF 
[ ] Tidy
[ ] Wddx
[ ] XSL 
[XXmlRPC   
[ ] Zend Multibyte
[ ] Zip 
[XZlib (Requires that zlib is installed and up to date [Save and build

ثم ادخل إلى WHMوعدل الخيارات التالي :
Default PHP Version (.php files) >>>>> 5
PHP 5 Handler >>>>>> dso
PHP 5 Handler >>>>>> none
Suexec >>>>>>> on
ملاحظة : أذا كنت تريد تركيب Modsecurity   في هذي الحالة سوف تحتاج إلى الموديل Uniqueld ,
ملاحظة : لا تنفذ التحديث ألي في الأوقات التي يكون الضغط على الخادم قليل

Main >> Service Configuration >> Configure PHP and SuExec

بريطاني من اصول عربية، مقيم في انجلترا. مدون منذ اكثر من 15 سنة، ومحب للقراءة والبحث. طالب في كلية الهندسة تخصص كهرباء والكترونيات. وبشكل جانبي اقوم بصناعة الموسيقى، وانا متخصص بشكل ادق في مجال هندسة الماسترنج والمكساج للاعمال الموسيقية والفنية. وقبلها وفي السنوات السابقة بين ٢٠٠٥ و ٢٠١٣ ركزت في مجال امن المعلومات والادارة والاوتوميشين لانظمة التشغيل والسيرفرات، وعملت مع مجموعة متنوعة من المواقع العربية، وخاصة الصحف الالكترونية والمواقع الحكومية في منطقة الخليج، من حيث تهيئة وحماية وادارة البنية التحتية لمواقعهم الالكترونية.

‎التعليقات‫:‬ 2 On Apache And Php Update

شاركني برأيك